BETA

31st October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [31/10/18 09:27 AM] with 'Partial Outage'

Issue has been resolved at [31/10/18 09:30 AM]