BETA

1st September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [01/09/19 01:15 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [01/09/19 01:43 PM]