BETA

1st September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [01/09/19 11:47 AM] with 'Partial Outage'

Issue has been resolved at [01/09/19 11:54 AM]