BETA

1st September 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [01/09/19 03:37 AM] with 'Partial Outage'

Issue has been resolved at [01/09/19 04:01 AM]