BETA

4th May 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [04/05/17 07:35 AM] with 'Major Outage'

Issue has been resolved at [04/05/17 07:36 AM]