BETA

31st October 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [31/10/18 06:09 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [31/10/18 09:52 AM]