BETA

31st October 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [31/10/18 06:09 AM] with 'Partial Outage'

Issue has been resolved at [31/10/18 06:10 AM]