BETA

30th August 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [30/08/19 03:31 PM] with 'Major Outage'

Issue has been resolved at [30/08/19 03:37 PM]