BETA

30th October 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [30/10/18 08:39 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/10/18 09:03 PM]