BETA Singapore cluster       Mumbai cluster

30th August 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [30/08/19 03:23 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/08/19 03:29 PM]