BETA

4th May 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [04/05/17 07:35 AM] with 'Partial Outage'

Issue has been resolved at [04/05/17 07:38 AM]