BETA

30th August 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [30/08/19 03:07 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/08/19 03:17 PM]