BETA

31st October 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [30/10/18 06:51 PM] with 'Partial Outage'

Issue has been resolved at [30/10/18 06:57 PM]