BETA Singapore cluster       Mumbai cluster

30th August 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [30/08/19 12:16 PM] with 'Partial Outage'

Issue has been resolved at [30/08/19 12:33 PM]