BETA

28th August 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [28/08/19 01:44 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/08/19 02:17 PM]