BETA

27th August 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [27/08/19 04:42 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/08/19 01:50 AM]