BETA

27th August 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [27/08/19 01:41 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [27/08/19 02:04 AM]