BETA

16th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [16/03/19 12:24 AM] with 'Partial Outage'

Issue has been resolved at [16/03/19 12:25 AM]