BETA Singapore cluster       Mumbai cluster

24th August 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [24/08/19 02:01 PM] with 'Partial Outage'

Issue has been resolved at [24/08/19 02:19 PM]