BETA

28th October 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [28/10/18 04:22 PM] with 'Partial Outage'

Issue has been resolved at [28/10/18 04:24 PM]