BETA

18th August 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [18/08/19 05:20 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [18/08/19 05:42 PM]