BETA Singapore cluster       Mumbai cluster

18th August 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [18/08/19 04:56 PM] with 'Partial Outage'

Issue has been resolved at [18/08/19 05:16 PM]