BETA

28th October 2018

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [28/10/18 01:25 AM] with 'Partial Outage'

Issue has been resolved at [28/10/18 01:28 AM]