BETA

27th October 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [27/10/18 06:41 PM] with 'Major Outage'

Issue has been resolved at [27/10/18 06:45 PM]