BETA

17th August 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [17/08/19 01:11 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [17/08/19 01:35 PM]