BETA

27th October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [27/10/18 02:22 PM] with 'Partial Outage'

Issue has been resolved at [27/10/18 02:25 PM]