BETA

27th October 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [27/10/18 03:51 AM] with 'Partial Outage'

Issue has been resolved at [27/10/18 03:57 AM]