BETA

4th May 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [04/05/17 07:20 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [04/05/17 07:25 AM]