BETA

27th October 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [27/10/18 02:46 AM] with 'Partial Outage'

Issue has been resolved at [27/10/18 02:48 AM]