BETA

26th October 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [26/10/18 01:12 AM] with 'Major Outage'

Issue has been resolved at [26/10/18 01:15 AM]