BETA

26th October 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [26/10/18 12:52 AM] with 'Major Outage'

Issue has been resolved at [26/10/18 01:07 AM]