BETA

26th October 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [26/10/18 12:52 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/10/18 01:07 AM]