BETA

24th October 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [24/10/18 02:32 PM] with 'Major Outage'

Issue has been resolved at [24/10/18 02:33 PM]