BETA

23rd October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [23/10/18 01:23 PM] with 'Partial Outage'

Issue has been resolved at [23/10/18 01:25 PM]