BETA

22nd July 2016

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/07/16 08:04 PM] with 'Partial Outage'

Issue has been resolved at [22/07/16 08:05 PM]