BETA

11th August 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/08/19 10:19 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [21/08/19 01:09 PM]