BETA

11th August 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/08/19 07:07 PM] with 'Partial Outage'

Issue has been resolved at [11/08/19 07:11 PM]