BETA

10th August 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [10/08/19 11:56 AM] with 'Partial Outage'

Issue has been resolved at [10/08/19 11:58 AM]