BETA

22nd October 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/10/18 01:07 PM] with 'Partial Outage'

Issue has been resolved at [22/10/18 01:09 PM]