BETA

22nd October 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [22/10/18 11:28 AM] with 'Partial Outage'

Issue has been resolved at [22/10/18 11:32 AM]