BETA

22nd October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/10/18 10:24 AM] with 'Partial Outage'

Issue has been resolved at [22/10/18 10:25 AM]