BETA Singapore cluster       Mumbai cluster

8th August 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [08/08/19 09:04 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [09/08/19 02:11 PM]