BETA

8th August 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [08/08/19 12:11 AM] with 'Partial Outage'

Issue has been resolved at [08/08/19 12:24 AM]