BETA

21st October 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [21/10/18 08:48 PM] with 'Major Outage'

Issue has been resolved at [21/10/18 08:50 PM]