BETA

21st October 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [21/10/18 11:22 AM] with 'Partial Outage'

Issue has been resolved at [21/10/18 11:23 AM]