BETA

15th March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [15/03/19 08:03 PM] with 'Partial Outage'

Issue has been resolved at [15/03/19 08:06 PM]