BETA

20th October 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [20/10/18 01:17 PM] with 'Major Outage'

Issue has been resolved at [20/10/18 01:39 PM]