BETA

20th October 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [20/10/18 01:16 PM] with 'Partial Outage'

Issue has been resolved at [20/10/18 01:39 PM]