BETA

20th October 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [20/10/18 01:00 PM] with 'Major Outage'

Issue has been resolved at [20/10/18 01:39 PM]