BETA

20th October 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [20/10/18 12:58 PM] with 'Partial Outage'

Issue has been resolved at [20/10/18 01:39 PM]